Interaktivna multimedija - tretji sklop vaj

Naloga 1 - spreminjanje videza obstojece predstavitve

Radi bi naredili prezentacijo, ki bi vsebovala video s predavanja in prosojnice, podobno kot na strani
Videolectures, npr: http://videolectures.net/phpkonferenca08 stamcar php. Odlocili smo se, da bomo
prezentacijo naredili v Flash-u, kot samostojno aplikacijo. Po krajSem brskanju po spletu smo na spletni
strani podjetja Adobe http://www.adobe.com/devnet/flash/articles/vidtemplate corppreso.html nasli
nekaj zelo podobnega, kot vidimo na spodniji sliki:

Synchronized Video Presentation
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Na levi strani aplikacije se nahaja video, na desni se pojavlja tekst, ki je z videom sinhroniziran. V
spodnjem delu se nahajajo gumbi za navigacijo po posameznih delih videa. Ker nam je koncept vsec in
ker je dostopna tudi izvorna koda, se odlo¢imo, da bomo naso predstavitev naredili tako, da bomo
najdeno predstavitev nekoliko spremenili in jo prilagodili nasim potrebam.

Spoznavanje najdene predstavitve

Izvorne datoteke za predstavitev najdemo v direktoriju vaja3-1/videoSync. lzvorne datoteke so sicer
dostopne tudi na spletnem naslovu

http://download.macromedia.com/pub/developer/vidtemplate synch preso cs4.zip, a so datoteke v
formatu Adobe Flash CS4 in jih Flash CS3 ne odpre.

V Flashu odpremo datoteko SyncVideoPreso.fla in datoteko /code/SyncVideoPreso.as. Preden zathemo
s spreminjanjem posameznih elementov prezentacije, se bomo najprej z le-to bolje spoznali.

Na Timeline-u, ki ga poznamo Ze od prej, imamo tokrat Sest layer-jev (plasti) in sicer:


http://videolectures.net/phpkonferenca08_stamcar_php
http://www.adobe.com/devnet/flash/articles/vidtemplate_corppreso.html
http://download.macromedia.com/pub/developer/vidtemplate_synch_preso_cs4.zip

e Background — ozadje aplikacije, to je sivi okvir v katerem se nahajajo video, tekst in gumbi.

e FLVPlayback — komponenta za prikaz .flv videa

e Buttons — gumbi za navigacijo in njihove oznake (labels)

o Content —vsebina, ki se predvaja desno od okna z videom. Ta layer je razdeljen na keyframe, ki
ustrezajo posameznim napisom, ki se prikazujejo.

e Title — tekstovno polje, ki vsebuje naslov prezentacije (Synchronised Video Presentation)

e Action & Labels —To je pomozni layer, ki je razdeljen na enake keyframe kot layer Content, le
da so keyframi v tem layerju poimenovani. Kode tokrat v tem layerju ni, razen stop() v prvem
keyframe-u.
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Ce si prezentacije Ze nismo ogledali na spletni strani, si jo ogledamo sedaj s klikom na Ctrl + Enter.
Prezentacija deluje na naslednji nacin:

Video posnetek vsebuje kontrolne tocke, oziroma cue points. Vsaka kontrolna tocka ima dolo¢eno ime
in Cas, ko nastopi. Imena kontrolnih tock ustrezajo imenom navigacijskih gumbov in keyframe-ov na
layer-u Action&Labels. Na ta nacin je implementirana povezava in sinhronizacija med video posnetkom,
gumbi in vsebino. Kontrolne tocke lahko dodamo v Flash-u ali pa jih vgradimo v video med samim
kodiranjem videa. To¢ke dodane med kodiranjem videa so bolj natanc¢ne.



Layer Actions & Labels je razdeljen na keyframe (kljucne slike). Imena teh keyframe-ov ustrezajo
imenom gumbov in kontrolnih tock (cue points).

Layer Content je tudi razdeljen na keyframe, vsak keyframe pa vsebuje tisto vsebino, ki bo v tem
trenutku predvajana. Trenutek predvajanja pa je dolocen z ustrezno kontrolno tocko iz videa, ki je
poimenovana enako kot ekvivalentni keyframe v layerju Actions & Labels.

Layer Buttons vsebuje gumbe za navigacijo po video posnetku. Imena gumbov so ista kot imena
kontrolnih tock in keyframe-ov, s to razliko, da imajo na koncu Se dodatek »_btn«.

Datoteka SyncVideoPreso.as pa vsebuje kodo, ki poskrbi za sinhronizacijo in zdruZevanje kontrolnih
tock, imen gumbov in keyframe-ov.

Ko zazenemo prezentacijo, se samodejno zacne predvajanje videa. Prva kontrolna tocka v videu je
introduction in sicer nastopi Ze v sekundi 00. Koda v datoteki SyncVideoPreso.as to zazna in sprozi zelen
sij okrog gumba z imenom introduction_btn. Isto¢asno koda poskrbi za to, da se desno od videa zacne
predvajanje vsebine, ki se nahaja v layer-ju Content, v keyframe-u z imenom introduction.

Ce pa uporabnik med predvajanjem klikne na nek gumb, poteka postopek na isti nacin, samo v nasprotni
smeri. Koda zazna, da je uporabnik kliknil na gumb in prebere ime gumba. Glede na ime gumba postavi
video na ustrezno kontrolno tocko in predvaja vsebino, ki se nahaja v keyframe-u z istim imenom kot
omenjena kontrolna tocka in gumb.

Spreminjanje videza ozadja
V timeline-u izberemo layer Background, v primeru da je zaklenjen (ikonica kljucavnice izbrana), pa ga Se

odklenemo.
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Na sceni se pojavi moder okvir okoli slike ozadja.
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Synchronized Video Presentation Full Screen

Dvakrat kliknemo na sliko ozadja na sceni in se nam odpre grafika ozadja, ki jo lahko spreminjamo po
zZelji. Grafika je sestavljena iz dveh slik in sicer velikega belega pravokotnika in sivih okvirjev.

S pomocjo grafi¢nih orodij v toolbaru lahko grafiko ozadja poljubno spreminjamo. Lahko recimo
pobarvamo beli pravokotnik v ¢rno, okvirje pa vse v belo:
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Kliknemo na Scene 1 , prezentacijo shranimo in jo testiramo.

Ce nam rezultat ni vie¢, nekajkrat stisnemo Ctrl+Z (ali pa Edit->Undo), dokler ni videz spet taksen, kot je
bil pred spremembami. Nato lahko spet izberemo sliko ozadja in jo pobriSemo, ali pa jo zamenjamo z
neko drugo sliko (File->Import->Import to stage).



Ceprav se nahaja v posebnem layer-ju (Title), tudi naslov prezentacije sodi v videz ozadja. Izberemo ga

lahko s klikom nanj, po dvojnem kliku pa ga lahko tudi spremenimo.
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Spreminjanje vsebine
Vsebine, ki se predvajajo ob videu, se nahajajo v layer-ju Content in so razdeljene po keyframe-ih.

V tej prezentaciji so vsebine v obliki animacij, ki prikazujejo tekst, tako kot na spodniji sliki.

Da dostopimo do posameznih vsebin, kliknemo na enega izmed keyframe-ov na layer-ju Content. Na
sceni se pojavi moder okvir, znotraj katerega je animacija. Okvir je videti prazen zato, ker animacija
prikazuje tekst, ki se pocasi pojavlja. Prvi frame je prazen, ker se tekst Se ni pojavil.
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Mi se z animacijo ne bomo ukvarjali, zato bomo obstojeco vsebino zamenjali z nasim besedilom, ki pa
bo staticno. Vmes lahko dodamo tudi kaksno sliko. To naredimo na naslednji nacin:

Ko izberemo doloceno vsebino, jo enostavno izbriSemo (Del). Na timeline-u opazimo, da je layer Content
sedaj na tem mestu bel, oziroma prazen.
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Izberemo orodje za vnos teksta (Text tool), kliknemo na mesto, kjer je bila izbrisana stara vsebina in
nekaj napisemo.
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Izbrani keyframe na layer-ju Content postane spet siv. Shranimo in testiramo prezentacijo.

Spreminjanje videza navigacijskih gumbov
Obstojecim gumbom lahko spremenimo polozaj, napis, grafi¢cno podobo, barvo sija okrog izbranega
gumba, velikost; gumbe lahko zbriSemo in jih dodamo.
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PoloZaj gumbov spreminjamo enostavno tako, da gumb z misko premaknemo na Zeljeni polozaj. Napis
na gumbu je samostojen element, zato ga moramo premakniti posebej. Pri premikanju mora biti izbrano
orodje Selection iz toolboxa (zgornja, ¢rna puscica).

Napis na gumbu spremenimo tako, da ga izberemo z orodjem Text Tool in nato spremenimo obstojeci
napis.

Grafi¢no podobo gumba spremenimo tako, da na gumb dvakrat kliknemo. Pri tem je najbolje, ¢e
kliknemo nekje na rob gumba, drugace bomo verjetno izbrali napis na gumbu. S tem vstopimo v timeline
gumba, kjer lahko po Zelji spreminjamo layerje iz katerih je gumb sestavljen in njihove keyframe.
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Barva sija je za vse gumbe enaka, zato je dolo¢ena samo na enem mestu in sicer v movie clipu
CustomButtonSelected, ki ga najdemo v knjiznici.
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Z dvojnim klikom na modro ikono se nam na sceni odpre grafi¢na vsebina sija. Ta je sestavljen iz tirih
stranic. Da spremenimo barvo stranice, kliknemo nanjo in izberemo novo barvo iz palete:
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Kliknemo na Scene 1 , shranimo spremembe in testiramo prezentacijo.

Velikost gumba spremenimo tako, da gumb izberemo, nato pa kliknemo na orodje Free Transform Tool.

%!

~— |. Sedaj lahko z miSko spreminjamo velikost gumba. Ko smo z velikostjo zadovoljni, izberemo spet
orodje Select (¢rna puscica), prezentacijo shranimo in jo testiramo.

Gumb izbriSemo tako, da ga izberemo in kliknemo Del. Paziti moramo, da izbriS$emo tudi napis.

Gumb najlaZje dodamo tako, da izberemo obstojeci gumb, ga kopiramo (copy) in nato zalepimo (paste)
ter ustrezno popravimo. Prostor za novi gumb lahko naredimo tako, da obstojece gumbe zmanjsamo,
ker pa polozaj gumba ni pomemben, lahko novi gumb postavimo kjerkoli. Pri kopiranju in lepljenju
gumbov moramo biti pozorni na to, da ima vsak gumb drugacno ime (instance name). Ce recimo
izberemo prvi gumb (Introduction) in pogledamo v panel Properties, bomo videli, da je ime inStance
gumba introduction_btn:
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* Properties % | Parameters | Filters |

“ Button ~ | Instance of: CustomButton Color: |None w
— | introduction_btmn Track as button ~
Wi 129.9 | x| 296.3 Blend: | Mormal w
& H: 29.0 y:| 378.1 DUSE runtime bitmap ci

Ko zalepimo (paste) nas novi gumb, bo imel isto ime kot gumb, ki smo ga kopirali. Zato moramo novemu
gumbu spremeniti ime instance. Novi gumb bo brez napisa, ki ga dodamo z orodjem Text Tool.

Spreminjanje videza predvajanega videa
V Flash aplikaciji vidimo, da je video predstavljen v obliki ¢rnega pravokotnika, ki je postavljen v
FLVPlayback layer. Lahko spremenimo velikost in polozZaj videa, lahko mu dodamo nove Ul komponente,

spremenimo kontrolne tocke (cue points) in lahko spremenimo vir videa.

Velikost videa spreminjamo na isti nacin kot velikost gumbov in sicer z orodjem Free Transform Tool.
Polozaj videa spreminjamo na isti nacin kot polozZaj gumbov in sicer ga premaknemo z misko.

Ko predvajamo prezentacijo lahko opazimo, da video ne vsebuje nobenih Ul komponent (kontrolnih
gumbov play, stop, volume...), najverjetneje iz estetskih razlogov. Ce 7elimo dodati kaken gumb,
odpremo panel Components (Window -> Components), izberemo Zeljeni gumb in ga prevle¢emo na
sceno. Ce nas Flash vpraga ¢e Zelimo nadomestiti obstoje¢o komponento, odgovorimo Yes.
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Do kontrolnih tock dostopimo tako, da izberemo video s klikom na rdeco ikono in nato odpremo panel
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Components Inspector (Window -> Components Inspector).

Component Inspedor x

B FLvPlayback, <display> gl
Parameters | Bindings | Schema

Name Value

align center

autoFlay true

cuePoints [[fintroduction,00:00:00.000 1 G

preview Mone

scaleMode maintainAspectRatio

skin Mone

skinAutoHide false

skinBackgroundalpha |0.85

skinBackgroundColor | #474BCE [

source video/Call_to_action. fiv

valume 1

Z dvojnim klikom na parameter cuePoints odpremo okno za urejanje kontrolnih tock (Flash Video Cue

Points).
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Cue Points
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Mame
introduction
tellaFriend
trialDownload
salesRep
onlineStore

Time:
00:00:00,000
00:00:10.042
00:00:16.779
a0:00:22,372
00:00:25.601

Type
Mavigation
Mavigation
Mavigation
Mavigation
Mavigation

Mote: Event and Mavigation cue points are not editable,
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S klikom na ikono »+« dodamo novo tocko, s klikom na ikono »-« pa tocko zbriSemo. Pri tem se moramo

zavedati, da lahko brisemo, urejamo in dodajamo samo kontrolne tocke tipa ActionScript cue point.

Tocke, ki so tukaj prisotne so tipa Navigation in jih ne moremo spreminjati, lahko jih le onemogocimo.

Vec o kontrolnih to¢kah bomo povedali v drugem delu tretje vaje.

Video, ki se v prezentaciji predvaja zamenjamo tako, da izberemo video s klikom na rdeco ikono in nato

odpremo panel Components Inspector (Window -> Components Inspector). Nato kliknemo na polje

source in izberemo drugi video s koncnico .flv.



